I have been using Compaq Visual Fortran 6.6 and Visual Studio 6.0 for years. I finally
decided it is time to do whatever it takes to upgrade to the latest Fortran and C++
compilers. Neither of these old compilers are supported and they are not compatible with
Windows Vista.

I have found that there is not that much information on how to efficiently upgrade to the
new compilers. There are some simple examples of mixed Fortran programming that
come with the Intel® compiler, but they were not quite complex enough to address the
problems that I was encountering. However, you should refer to them because they do
provide some insight into mixed language programming with the new compilers. Also,
there is some documentation on mixed language programming and integrating with
Visual Studio IDE. You should review all of this documentation if you can find it.

I am posting this in the hopes that you may learn from my experiences. I upgraded to
Visual Studio 2008 and Compaq Visual Fortran 10.1. As a side note, I just needed to get
these compilers working for my code and I have not investigated all aspects of either
compiler and do not consider myself an expert.

My code consists of 10 of thousands of lines of C++ codes with comparable amount of
Fortran code. The Fortran code is compiled as the primary project and the C code is
compiled as a static object library in a C++ dependent project.

Under CVF/VS6 the code compiled in about 1 and a half minutes on my computer. After
the upgrade to VS2008/INTEL® 10.1 it now compiles in about 5 and a half minutes.
This is over three times longer.

Here are some installation notes about installing INTEL® Fortran with Visual Studio:
http://www.intel.com/software/products/compilers/docs/fwin/install.htm

Below of the key things to keep in mind when changing from CVF/VS6 to the new
compilers:

1. You need to is install your Visual Studio software before installing the Fortran. 1
have both VS2005 and VS2008 installed on my system and Intel® Fortran works
with both of them.

a) Install VS2008
b) Install any updates to VS2008
c) Install Intel® Fortran

To determine if you have installed the compilers correctly, in Visual Studio 2008,
Select File->New Project and verify that Intel® Fortran is an option.



>4
&

New Project

File Edt Wiew Toals Test Window Help
e T - NI R W T T = = W | If -| [# OnCrossRead vﬂﬁg‘g}@mg-i
Solution Explarer ~ 1 X StartPage

Microsoft*

Visual Studio 2008

Visual C++ Developer Center

a Now Available
MNET Framework 3.5 5P1 Beta
wditionally, 5P1 for the NET
OLNET Data Services.,

HET Framewark 35 v |5

=) Intel(R) Fortran

- Console Application
Library
Quickitfin Application
Windowing Application
COM Server

[ Other Languages

& Mbher Praieck Tunes

|

Project types: Templates: | oty
= Visual C++ # |  visual Studio installed templates Bts introduces Full support For
ATL esigriers, impraved Web
Clr [Elactiver Dialog Code [=]Activex MDI Code dation Server enhancemerts,
General [Elactivex 50t Code [=]pialog Code 2008 Feature Pack
MFC [ElErmpty Praject [=]m1 Code k=5 of the new Visual C++
Smart Device =ls01 cods et
Test |
Wina2 || My Templates ual C++ 2008 Feature Pack is
[ ————— iting features for C++

(-i5earch Online Templates.

ation of TR1.

decided to reinvest in MFC,
tio we turned ko BOGSoft For
mponerts for MFC and JNET,
g Far. Check auk more on

& praject for creating an application with a Windows user interface

indows Server 2008, ¥isual
jucts provide a secure and

HMame:

Location:

Solution flare [ W

| windgp1

| ons. Learn mare aboLk these
e.com.

| FaUMCPY_prajectsivised_23G_Vs08

v| [eowse.. ]

| [Ccreate directary For solution

55 Edition provides a powerful
Hows and col 20/3D games.

PoweITUl Vet SMple New Way to deVelop your on dames.

Windows with C+-+: Windows Temblate Librarv 8.0

heators have partriered to
2008 users, Try out this

[xomeoL |

By far the easiest way to convert from CVF6.6/VS6 is to use the upgrade tools
that are provided. I was hesitant to do this at first, but there are so many options

that needed to be tweaked by hand that it takes a long time to determine the right
combination and the upgrade tools take you most of the way. To do the
automatic upgrade do the following:

Open Project

a) In Visual Studio select the dsw file for the CVF
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c) Select “Yes”, since I am doing both a Fortranand C linked project , it will
ask to convert the second dependent project.
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d) Select “Yes”, then select Project->Extract Compaq Visual Fortran Project
Items.
e) This will complete the conversion process. Now do a rebuild all and
resolve any remaining issues that you encounter
Additional items that I had to address for my project are included below:
a) Inthe C++ files replace
#include <fstream.h>
with
#include <fstream>
using namespace std;

b) In the C++ files replace
#include <iostream.h>
with
#include <iostream>
using namespace std;

c) Ifthe VS6/CVF project had additional include directories set in VS6 (Tools-
>Options->Directories), you need to set them in the project.
a. Right click on the Fortran project
b. Select properties.



c. Select the Fortran->General page
d. Set the include directory under “Additional Include Directories”
e. For my case:

F:\MCNPX projects\MCNPX SRC\MCNPX26E\v26e\src\include

d) The Fortran Preprocessor Definitions did not get converted correctly, need to
add a ;" after each definition in the Project.

g)

a. Right click on the Fortran project

b. Select properties.

c. Select the Fortran->General page

d. Add semi-colons in “Preprocessor Definitions”

In the VS6 Project I had added the CVF Fortran library*“dformt.lib” to link to
(Project->Settings; Link tab). Remove this from the INTEL/VS2008 project.

a. Right click on the Fortran project

b. Select properties.

c. Select the Linker->Input

d. Remove the library “dformt.lib” from “Additional Dependencies”

When Linking I get the errors:

mo a0 o

1>nafxcwd.lib (afxmem.obj) : error LNK2005: "void * _ cdecl operator

new (unsigned int)" (??2@YAPAXIQ@Z) already defined in LIBCMTD.lib (new.obj)
1>nafxcwd.lib (afxmem.obj) : error LNK2005: "void  cdecl operator

delete (void *)" (??3Q@YAXPAXQ@Z) already defined in LIBCMTD.1lib (dbgdel.obj)
1>nafxcwd.lib (afxmem.obj) : error LNK2005: "void _ cdecl operator
delete[] (void *)" (2??_ VR@YAXPAX@Z) already defined in

LIBCMTD.1lib (delete2.0bj)

This is because of the order that the libraries are linked:
http://support.microsoft.com/kb/148652

Right click on the Fortran project

Select properties.

Select the Linker->Input

For “Ignore Specific Library” add: nafxcwd.lib;Libcmtd.lib

For “Additional Depdencies add: nafxcwd.lib Libcmtd.lib ( now semi
colon here)

After making the above change I still get the error:

oac o

1>nafxcwd.lib (afxmem.obj) : error LNK2005: "void  cdecl operator
delete (void *)" (??3@YAXPAX@Z) already defined in Libcmtd.lib (dbgdel.obj)

Not sure why I get this error, so use /FORCE on the command line to
force the code to link.

Right click on the Fortran project

Select properties.

Select the Linker->Command Line

Add /FORCE to the command line to force a link.

h) For the error:

error LNK2019: unresolved external symbol SIGNAL@]12 referenced in
function TTYINT



add:
use IFPORT to the Fortran program

1) For the error:
error LNK2019: unresolved external symbol GETENV@16 referenced in
function MCNP

add:
use IFPORT to the Fortran program

j) For the error:
error LNK2019: unresolved external symbol ETIME@4 referenced in
function SECND

add:
use IFPORT to the Fortran program

k) If the compiler then complains “Please specify the name of the executable file
to be used for the debug session:” then Select browse and browse to the
location of the executable (not sure why it can not find it on its own).



Create by Hand:

If you decide you do not want to do the automatic update, you can do the conversion by
hand. Below are the options I needed to set to get my code to work with the new
compilers. Some of these options are specific to my program, but others are generic to
the conversion process.

Create new project Fortran->Windowing Application->Empty Project
Set the name and directory (Name: and Location: )
Create directories and add files to the Fortran Project
Under Fortran->General
a. Additional Include Directories:
F:\MCNPX_projectssMCNPX_ SRC\MCNPX26F\v26f\src\include
b. Preprocessor Definitions:
INTEL; VISCOLORS; VECAD; VISED; CINDER; DEC; XS64;
MESHTAL; RADIOG; CEM; HISTP; SPABI; DFACT; INCL; PLOT;
MCPLOT; GKSSIM; CHEAP
5. Under Fortran->Preprocessor
a. Preprocess Source File:
Yes
6. Under Fortran->Diagnostics
a. Generate Interface Blocks:
No
b. Check Routine Interfaces:
No
7. Under Fortran->Data
a. Local Variable Storage
All Variables Save (/Qsave)
8. Under Fortran->External Procedures
a. Calling Convention
CVF(/iface:cvf)
9. Under Fortran->Run-time
a. Check Array and String Bounds
No
10. Under Linker->Input
a. Additional Dependencies
nafxcwd.lib Libemtd.lib OPENGL32.LIB GLU32.LIB Htmlhelp.lib
(nafxcw.lib Libcmt.lib ... on Release)
b. Ignore Specific Library
nafxcwd.lib; Libcmtd.lib
(nafxcw.lib;Libecmt.lib on Release)
11. Under Linker->System
a. Heap Reserve Size
83886080
b. Stack Reserve Size

P



67108864
c. Enable Large Addresses
Support Addresses Larger than 2 CB (/LARGEADDRESSAWARE)

12. Under Linker->Command Line

(98]

a. add
/MACHINE:I1386 /FORCE

. File-> new-> project Visual C++->MFC->MFC DLL

a. Set Name: to
vislib
b. Set Solution: to
Add to Solution
c. Select OK, then Finish
Delete any .c and .h files that have been created
Add the c files to the project (Add->Existing Item).
Under General
a. Configuration Type
Static Library (.lib)
b. Use of MFC
Use MFC in a Static Library
c. Character Set
Use Multi-Byte Character Set
Under Debugging
a. Command
F:\MCNPX projects\VISEDX 23E_VS2008\visedX23E\Debug\visedx
23e.exe
C/C++->Preprocessor (C/C++ will not show up if you have not added files)
a. Preprocessor Definitions
Remove USRDLL
C/C++->Code Generation
a. Runtime Library
Multi-threaded Debug (/Mtd)
(Multi-threaded /MT on Release)
C/C++->Precompiled Headers
a. Create/Use Precompiled Header
Not Using Precompiled Headers
Right click on the Fortran Project
b. Select Project Dependencies
Click on the “vislib” check box

10. Right click on the Fortran Project and add a vised files directory

c. Add
Vised2.rc



The Rest of the Story:

File-> new-> project Visual C++->MFC->MFC Application
Set the name and directory (Name: and Location: )
Select OK, then Finish
Delete any .c and .h files that have been created
Add the c files to the project (Add->Existing Item).
Right click on the project, select properties
Under General
a. Use of MFC
Use MFC in a Static Library
b. Character Set
Use Multi-Byte Character Set
8. C/C++->Code Generation
a. Runtime Library
Multi-threaded Debug (/Mtd)
(Multi-threaded /MT on Release)
9. C/C++->Precompiled Headers
a. Create/Use Precompiled Header
Not Using Precompiled Headers
10. Under Linker->General
a. Additional Library Directories
C:\Program Files\Intel\Compiler\Fortran\10.1.021\IA32\Lib
11. Under Linker->Input
b. Additional Dependencies
OPENGL32.LIB GLU32.LIB Htmlhelp.lib
12. Under Linker->System
c. Heap Reserve Size
83886080
d. Stack Reserve Size
67108864
e. Enable Large Addresses

NowunhkwWd =

Support Addresses Larger than 2 CB (/LARGEADDRESSAWARE)

13. Select OK to exit the property pages

14. Create new project Fortran->Library->Static Library
a. Set Name: to
flib
b. Set Solution: to
Add to Solution
c. Select OK
15. Create directories and add files to the Fortran Project
16. Under Fortran->General
a. Additional Include Directories:
F:\MCNPX projectssMCNPX_SRC\MCNPX26F\v26f\src\include



b. Preprocessor Definitions:
INTEL; VISCOLORS; VECAD; VISED; CINDER; DEC; XS64;
MESHTAL; RADIOG; CEM; HISTP; SPABI; DFACT; INCL; PLOT;
MCPLOT; GKSSIM; CHEAP

17. Under Fortran->Preprocessor
a. Preprocess Source File:
Yes
18. Under Fortran->Diagnostics
a. Generate Interface Blocks:
No
b. Check Routine Interfaces:
No
19. Under Fortran->Data
a. Local Variable Storage
All Variables Save (/Qsave)
20. Under Fortran->External Procedures

a. Calling Convention
CVF(/iface:cvf)

21. Under Fortran->Run-time

a. Check Array and String Bounds
No

21 Right click on the C++ Project

a. Select Project Dependencies

Click on the “flib” check box



When Compiling without the Visual Editor
1. You must change Linker->System from Windows to Console

If you get this error:

There is no executable, change the C project form a .lib to a .exe
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